PSTN Calls Failing United States
Incident Report for Pexip Service
Resolved
We have returned the Pexip Service Number: +1-351-222-2275 back into the instructions on the dial-in instructions page and all numbers are operational at this time.
Posted Mar 23, 2020 - 19:15 UTC
Monitoring
While we work with our provider of the number +1-351-222-2275 we have updated our dial-in instruction page to now show +1-970-984-6000.
Posted Mar 23, 2020 - 18:15 UTC
Identified
We have identified an issue with one of our PSTN providers in the United States.

Users may experience difficulty connecting to the Pexip Service IVR when dialing Pexip Service Number: +1-351-222-2275

Users in the United States may also connect through another provider of ours using the number: +1-970-984-6000
Posted Mar 23, 2020 - 17:36 UTC
This incident affected: PSTN access.