check.videxio.com currently down please use https://portal.pexip.com/check-domain/
Incident Report for Pexip Service
Resolved
No further issues have been observed or reported and all systems are operational at this time.
Posted Jun 15, 2020 - 15:59 UTC
Monitoring
We have formaly put in place our portal tool to replace the server that check.videxio.com was previously on.

We are currently working through various workflows to make sure all former check.videxio.com links all work on the new tool.
Posted Jun 09, 2020 - 15:16 UTC
Identified
We have contacted our service provider for check.videxio.com to restore the service.

If a user is in need of check.videxio.com please direct them to: https://portal.pexip.com/check-domain/
Posted Jun 08, 2020 - 17:39 UTC