PSTN Service China Unavailable
Incident Report for Pexip Service
Resolved
The cause of the outage was identified and service has been restored.
Posted May 27, 2019 - 23:14 UTC
Investigating
Calls to the Pexip Cloud service using the PSTN gateway in China are currently failing.

We are currently investigating the cause of this outage.

For users in China please use the Hong Kong number to connect audio calls.
Posted May 27, 2019 - 03:22 UTC
This incident affected: PSTN accesss.