Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 22, 2025 - 10:00 UTC
Scheduled
The Infrastructure team will be performing certificate maintenance. This will affect all calling across all geographies.
Posted Mar 07, 2025 - 16:40 UTC
This scheduled maintenance affected: Control Center, Registration and Call Service, VMR service, Cloud Video Interop for Microsoft Teams, and Google Meet Interoperability Service.