Cloud OTJ Service Disruption Affecting M365 Mailboxes

Incident Report for Pexip Service

Monitoring

We have identified an issue affecting some Microsoft 365 tenants. The impact has been traced to a third-party application making mailbox queries through the Microsoft Graph API, which may result in degraded performance or unexpected behavior in Pexip Cloud OTJ.

Customers experiencing issues with Cloud OTJ are advised to open a support ticket so our team can review their environment and provide additional details and guidance.
Posted Feb 28, 2026 - 16:41 UTC

Update

We have contacted Microsoft to investigate this issue together with them.
Posted Feb 28, 2026 - 09:03 UTC

Investigating

We have observed a Cloud OTJ issue affecting some M365 mailboxes. Our Team is looking into it.
Posted Feb 28, 2026 - 09:00 UTC
This incident affects: One-Touch Join.