Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 21, 2024 - 10:00 UTC
Scheduled
We will be undergoing scheduled maintenance during this time. There is some possibility of calls being dropped during this time.
Posted Dec 19, 2024 - 15:20 UTC
This scheduled maintenance affected: Registration and Call Service, VMR service, Cloud Video Interop for Microsoft Teams, and Google Meet Interoperability Service.