Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 30, 2026 - 09:00 UTC
Scheduled
The Operations team will perform maintenance on the Partner Portal (portal.pexip.com). During the maintenance window, Pexip Infinity License generation and activation may be temporarily unavailable. All other Partner Portal functionality will remain available and operate normally.
Posted May 28, 2026 - 13:47 UTC
This scheduled maintenance affected: Partner Portal.