Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 22, 2025 - 10:00 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Feb 18, 2025 - 13:23 UTC
Update
The Pexip Service Ops team is conducting high-priority maintenance on our ingress SIP calling infrastructure. This may cause a brief disruption in VMR and Interop services for unregistered SIP devices. Users can redial immediately to reconnect their calls.
Posted Feb 18, 2025 - 13:22 UTC
Scheduled
The Infrastructure team will be performing network Maintenance affecting different services.
Posted Feb 11, 2025 - 16:04 UTC
This scheduled maintenance affected: Phone book, Provisioning service, One-Touch Join, PSTN access, QoS Backbone, Registration and Call Service, VMR service, Cloud Video Interop for Microsoft Teams, and Google Meet Interoperability Service.