Teams SIP Guest Join Fails for Teams Meetings with 15-Digit IDs

Incident Report for Pexip Service

Resolved

This incident has been resolved.
Posted Mar 30, 2026 - 14:12 UTC

Monitoring

A fix has been implemented for the issue. Teams Guest Join calls with 15-digit meeting IDs should now connect successfully.

Customers running the "Pexip Ad Hoc Join for Teams on Cisco endpoints" (https://help.pexip.com/macros/ad-hoc-join-teams.htm) need to update the msteams-macro-settings.js file to ensure the regex supports meeting IDs longer than 14 digits.
Posted Mar 30, 2026 - 13:05 UTC

Investigating

We are currently investigating an issue where Teams SIP Guest Join calls fail to connect when using 15-digit meeting IDs. Users attempting to join these meetings from SIP devices, Zoom, or Google Rooms may fail to connect.
Posted Mar 30, 2026 - 12:47 UTC
This incident affected: Connect for Microsoft Teams Meetings, Connect for Zoom Rooms, and Connect for Google Rooms.