Intermittent Microsoft Teams CVI and MTR Call Failures in the US Washington PoP

Incident Report for Pexip Service

Resolved

This incident has been resolved. Monitoring confirms no further issues since 2025-09-10 16:45 UTC, and all systems are functioning as expected.
Posted Sep 11, 2025 - 08:54 UTC

Monitoring

The network team has applied a fix for the QSF (US West) packet loss issue, and we are currently monitoring the results.
Posted Sep 10, 2025 - 16:51 UTC

Identified

We have identified a packet loss issue affecting calls routed through the QSF (US West) PoP and are working on remediation.
Posted Sep 10, 2025 - 16:25 UTC

Monitoring

Our checks indicate the issue is resolved and call functionality has returned to normal. We will continue monitoring to further verify.
Posted Sep 10, 2025 - 13:28 UTC

Identified

Since 11:50 AM UTC we have observed intermittent Microsoft Teams Cloud Video Interop (CVI) and Microsoft Teams Rooms (MTR) call failures caused by an issue in a third-party cloud provider’s infrastructure. As a mitigation, we are rerouting CVI and MTR calls to alternate locations and are closely monitoring the status of the provider’s incident.
Posted Sep 10, 2025 - 12:37 UTC
This incident affected: Cloud Video Interop for Microsoft Teams.