COVID-19 Proactive Bandwidth Reduction on the Pexip VMR Service
Incident Report for Pexip Service
Resolved
No further issues have been observed or reported and all systems are operational at this time.
Posted Jun 15, 2020 - 19:27 UTC
Update
Please note that due to the ongoing situation, demand on network services is extremely high globally and due to network congestion, quality issues outside the control of Pexip may sometimes occur. We are doing our utmost to ensure high quality collaboration can continue to be available to all our users.
Posted Mar 19, 2020 - 15:25 UTC
Monitoring
With the now global scale of COVID-19, we have observed many regional internet exchanges in APAC begin to struggle with the staggering demand. We expect this trend to continue into Europe and the Americas.

To proactively prepare for even greater demand, and to secure access to what is for many a critical communication tool, we have decided to reduce the maximum bandwidth per connection to the Pexip Service's virtual meeting platform to 768 kbps. The consequence will be that for certain video calls, you may see a lower resolution/image quality.

It is a special situation for everyone and we want to make sure all our customers can continue to collaborate reliably with the best possible quality.
Posted Mar 15, 2020 - 21:44 UTC
This incident affected: Public internet peering.