Microsoft Teams Rooms to VTC calling is failing.

Incident Report for Pexip Service

Resolved

This incident has been resolved.
Posted Oct 30, 2025 - 09:12 UTC

Monitoring

Microsoft Teams Rooms to VTC device calling is working again. We have implemented an interim measure recommended by Microsoft while services are degraded.
Posted Oct 29, 2025 - 18:57 UTC

Identified

There is an ongoing service degradation with Microsoft Azure, which is affecting calls from Microsoft Teams Rooms to VTC devices.

We are currently investigating a workaround to continue service while Microsoft Services are degraded.

Microsoft Status Page: https://status.cloud.microsoft/
Posted Oct 29, 2025 - 16:00 UTC
This incident affected: Connect for Microsoft Teams Rooms (MTRs).