PSTN Network Outage in CHINA
Incident Report for Pexip Service
Resolved
This incident has been resolved.
Posted 2 months ago. Jun 19, 2019 - 09:50 UTC
Investigating
An outage on the PSTN network for the Pexip service within China has been identified.

We are currently following up with our local telephony network partner to establish if there are any local service issues.
Posted 2 months ago. Jun 19, 2019 - 07:45 UTC