Degraded Quality in Calls from Webex Registered Devices in South Asia

Incident Report for Pexip Service

Resolved

This incident has been resolved.
Posted Apr 16, 2026 - 07:43 UTC

Monitoring

The previously observed packet loss affecting calls between Webex-registered endpoints in India and Pexip is no longer occurring and has remained stable for a period of time.

Based on available data, the issue appears to have been related to factors along the public internet path. We continue to monitor the situation to ensure call quality remains stable.
Posted Apr 15, 2026 - 09:05 UTC

Investigating

We are investigating a packet loss issue occurring between Cisco Webex and Pexip that is affecting calls from Webex-registered endpoints located in India. Participants connecting from their Webex devices may experience degraded call quality in the direction from the device to Pexip.
Posted Apr 14, 2026 - 15:18 UTC
This incident affected: Connect for Microsoft Teams Meetings and Connect for Google Meet Meetings.