PSTN Calls Failing Sweden
Incident Report for Pexip Service
Resolved
Our PSTN partner in Sweden has resolved their network outage, PSTN calling in the Sweden is fully operational.
Posted May 27, 2020 - 17:09 UTC
Identified
We have identified an issue with our PSTN provider.

Users can experience difficulty when dialing Pexip Service Number: + 46 858097888
Posted May 27, 2020 - 13:08 UTC
This incident affected: PSTN accesss.